Does SprintPHP have a

The place to go for any sort of help with using or developing with Sprint.
Post Reply
Batman
Posts: 1
Joined: 31 Oct 2017, 02:16

31 Oct 2017, 02:24

Trying to update the SprintPHP required packages, but this error comes up. I don't know where the PHP version (5.5.38) comes from. Any suggestions?

Code: Select all

$ composer update
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - This package requires php >=5.6 but your PHP version (5.5.38) does not satisfy that requirement.
  Problem 2
    - mockery/mockery dev-master requires php >=5.6.0 -> your PHP version (5.5.38) does not satisfy that requirement.
    - mockery/mockery dev-master requires php >=5.6.0 -> your PHP version (5.5.38) does not satisfy that requirement.
    - Installation request for mockery/mockery dev-master -> satisfiable by mockery/mockery[dev-master].
Running php version:

Code: Select all

$ php -version
PHP 7.1.8 (cli) (built: Aug 17 2017 11:34:56) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.1.0, Copyright (c) 1998-2017 Zend Technologies
    with Xdebug v2.5.0, Copyright (c) 2002-2016, by Derick Rethans

Post Reply